Aspose.ZIP For .NET Path Traversal

2019.01.10
Risk: Medium
Local: No
Remote: Yes
CVE: N/A
CWE: CWE-22

Aspose.ZIP for .NET was vulnerable to path traversal that allowed an attacker overwriting arbitrary file in a context of running application. The issue was fixed in version 19.1.0. Timeline: 04-10-2018 - Issue found and reported by email without reply. 10-10-2018 - Successfully reported in a private Aspose forum conversation 12-11-2018 - Vendor confirms that issue was fixed and will be released with 18.11.0 21-11-2018 - 18.11.0 is released 26-11-2018 - I finally notice a new version available, provide a different payload that is not mitigated. 29-11-2018 - Version 18.11.1 is released. I provide yet another bypass. 14-12-2018 - Vendor provides a release candidate for verification. 17-12-2018 - Another bypass is found. 31-12.2018 - New release candidate is provided. 03-01-2019 - Version 19.1.0 is released. Regards, Jaroslav LobaAevski


Vote for this issue:
50%
50%


 

Thanks for you vote!


 

Thanks for you comment!
Your message is in quarantine 48 hours.

Comment it here.


(*) - required fields.  
{{ x.nick }} | Date: {{ x.ux * 1000 | date:'yyyy-MM-dd' }} {{ x.ux * 1000 | date:'HH:mm' }} CET+1
{{ x.comment }}

Copyright 2019, cxsecurity.com

 

Back to Top