RSS   Vulnerabilities for
'Adaptive scalable texture compression encoder'
   RSS

2022-02-28
 
CVE-2021-44331

CWE-787
 

 
ARM astcenc 3.2.0 is vulnerable to Buffer Overflow in function encode_ise().

 
 
CVE-2021-43086

CWE-787
 

 
ARM astcenc 3.2.0 is vulnerable to Buffer Overflow. When the compression function of the astc-encoder project with -cl option was used, a stack-buffer-overflow occurred in function encode_ise() in function compress_symbolic_block_for_partition_2planes() in "/Source/astcenc_compress_symbolic.cpp".

 

 >>> Vendor: ARM 16 Products
Mbed tls
Arm trusted firmware
Arm-trusted-firmware
Cortex-a
Cortex-r
Trusted firmware-a
Mbed crypto
Mbed os
Arm compiler
Cortex-a72
Bifrost gpu kernel driver
Midguard gpu kernel driver
Valhall gpu kernel driver
Adaptive scalable texture compression encoder
Astc encoder
Trusted firmware-m


Copyright 2022, cxsecurity.com

 

Back to Top