RSS   Vulnerabilities for 'Aerospike server'   RSS

2020-08-05
 
CVE-2020-13151

CWE-78
 

 
Aerospike Community Edition 4.9.0.5 allows for unauthenticated submission and execution of user-defined functions (UDFs), written in Lua, as part of a database query. It attempts to restrict code execution by disabling os.execute() calls, but this is insufficient. Anyone with network access can use a crafted UDF to execute arbitrary OS commands on all nodes of the cluster at the permission level of the user running the Aerospike service.

 

 >>> Vendor: Aerospike 3 Products
Database server
Aerospike
Aerospike server


Copyright 2020, cxsecurity.com

 

Back to Top