RSS   Vulnerabilities for 'KEA'   RSS

2019-01-16
 
CVE-2018-5739

CWE-399
 

 
An extension to hooks capabilities which debuted in Kea 1.4.0 introduced a memory leak for operators who are using certain hooks library facilities. In order to support multiple requests simultaneously, Kea 1.4 added a callout handle store but unfortunately the initial implementation of this store does not properly free memory in every case. Hooks which make use of query4 or query6 parameters in their callouts can leak memory, resulting in the eventual exhaustion of available memory and subsequent failure of the server process. Affects Kea DHCP 1.4.0.

 
2015-12-22
 
CVE-2015-8373

 

 
The kea-dhcp4 and kea-dhcp6 servers 0.9.2 and 1.0.0-beta in ISC Kea, when certain debugging settings are used, allow remote attackers to cause a denial of service (daemon crash) via a malformed packet.

 

 >>> Vendor: ISC 7 Products
BIND
INN
Dhcp client
Dhcpd
DHCP
Dnsco bind
KEA


Copyright 2019, cxsecurity.com

 

Back to Top