RSS   Vulnerabilities for 'Moodle'   RSS

2022-05-18
 
CVE-2022-30597

NVD-CWE-Other
 

 
A flaw was found in moodle where the description user field was not hidden when being set as a hidden user field.

 
 
CVE-2022-30598

NVD-CWE-noinfo
 

 
A flaw was found in moodle where global search results could include author information on some activities where a user may not otherwise have access to it.

 
 
CVE-2022-30599

CWE-89
 

 
A flaw was found in moodle where an SQL injection risk was identified in Badges code relating to configuring criteria.

 
 
CVE-2022-30600

CWE-682
 

 
A flaw was found in moodle where logic used to count failed login attempts could result in the account lockout threshold being bypassed.

 
 
CVE-2022-30596

CWE-79
 

 
A flaw was found in moodle where ID numbers displayed when bulk allocating markers to assignments required additional sanitizing to prevent a stored XSS risk.

 
2022-03-25
 
CVE-2022-0983

CWE-89
 

 
An SQL injection risk was identified in Badges code relating to configuring criteria. Access to the relevant capability was limited to teachers and managers by default.

 
2022-03-11
 
CVE-2021-32472

CWE-200
 

 
Teachers exporting a forum in CSV format could receive a CSV of forums from all courses in some circumstances. Moodle versions 3.10 to 3.10.3, 3.9 to 3.9.6 and 3.8 to 3.8.8 are affected.

 
 
CVE-2021-32473

NVD-CWE-noinfo
 

 
It was possible for a student to view their quiz grade before it had been released, using a quiz web service. Moodle 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8, 3.5 to 3.5.17 and earlier unsupported versions are affected

 
 
CVE-2021-32474

CWE-89
 

 
An SQL injection risk existed on sites with MNet enabled and configured, via an XML-RPC call from the connected peer host. Note that this required site administrator access or access to the keypair. Moodle 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8, 3.5 to 3.5.17 and earlier unsupported versions are affected.

 
 
CVE-2021-32475

CWE-79
 

 
ID numbers displayed in the quiz grading report required additional sanitizing to prevent a stored XSS risk. Moodle 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8, 3.5 to 3.5.17 and earlier unsupported versions are affected.

 


Copyright 2022, cxsecurity.com

 

Back to Top