RSS   Vulnerabilities for 'Kvirc'   RSS

2010-08-02
 
CVE-2010-2785

CWE-Other
 

 
The IRC Protocol component in KVIrc 3.x and 4.x before r4693 does not properly handle \ (backslash) characters, which allows remote authenticated users to execute arbitrary CTCP commands via vectors involving \r and \40 sequences, a different vulnerability than CVE-2010-2451 and CVE-2010-2452.

 
2010-06-29
 
CVE-2010-2452

CWE-22
 

 
Directory traversal vulnerability in the DCC functionality in KVIrc 3.4 and 4.0 allows remote attackers to overwrite arbitrary files via unknown vectors.

 
 
CVE-2010-2451

CWE-134
 

 
Multiple format string vulnerabilities in the DCC functionality in KVIrc 3.4 and 4.0 have unspecified impact and remote attack vectors.

 
2009-08-25
 
CVE-2008-7070

CWE-94
 

 
Argument injection vulnerability in the URI handler in KVIrc 3.4.2 Shiny allows remote attackers to execute arbitrary commands via a " (quote) followed by command line switches in a (1) irc:///, (2) irc6:///, (3) ircs:///, or (4) and ircs6:/// URI. NOTE: this might be due to an incomplete fix for CVE-2007-2951.

 
2008-10-27
 
CVE-2008-4748

CWE-20
 

 
Format string vulnerability in the URI handler in KVirc 3.4.0, when set as the default application for processing IRC URIs, allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via format string specifiers in the irc:// URI.

 

 >>> Vendor: Kvirc 2 Products
Irc client
Kvirc


Copyright 2019, cxsecurity.com

 

Back to Top