Vulnerability CVE-2006-2554


Published: 2006-05-23   Modified: 2012-02-12

Description:
Buffer overflow in the tell_player_surr_changes function in Genecys 0.2 and earlier might allow remote attackers to execute arbitrary code via long arguments.

See advisories in our WLB2 database:
Topic
Author
Date
High
Buffer-overflow and NULL pointer crash in Genecys 0.2
Luigi Auriemma
25.05.2006

Type:

CWE-Other

CVSS2 => (AV:N/AC:L/Au:N/C:P/I:P/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
6.4/10
4.9/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
Partial
None
Affected software
Genecys -> Genecys 

 References:
http://aluigi.altervista.org/adv/genecysbof-adv.txt
http://lists.grok.org.uk/pipermail/full-disclosure/2006-May/046015.html
http://securityreason.com/securityalert/944
http://www.securityfocus.com/archive/1/433929/30/5010/threaded
http://www.securityfocus.com/bid/17969
http://www.vupen.com/english/advisories/2006/1815
https://exchange.xforce.ibmcloud.com/vulnerabilities/26519

Copyright 2020, cxsecurity.com

 

Back to Top