Vulnerability CVE-2006-7151


Published: 2007-03-07   Modified: 2012-02-12

Description:
Untrusted search path vulnerability in the libtool-ltdl library (libltdl.so) 1.5.22-2.3 in Fedora Core 5 might allow local users to execute arbitrary code via a malicious library in the (1) hwcap, (2) 0, and (3) nosegneg subdirectories.

See advisories in our WLB2 database:
Topic
Author
Date
Low
[Fedora] libtool-ltdl uses relative paths to resolve and load libraries
Enrico Scholz
09.03.2007

Type:

CWE-Other

CVSS2 => (AV:L/AC:M/Au:S/C:C/I:C/A:C)

CVSS Base Score
Impact Subscore
Exploitability Subscore
6.6/10
10/10
2.7/10
Exploit range
Attack complexity
Authentication
Local
Medium
Single time
Confidentiality impact
Integrity impact
Availability impact
Complete
Complete
Complete
Affected software
GNU -> Libtool-ltdl 

 References:
http://securityreason.com/securityalert/2378
http://www.securityfocus.com/archive/1/448153/100/0/threaded
http://www.securityfocus.com/bid/20434
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=209930

Copyright 2021, cxsecurity.com

 

Back to Top