Vulnerability CVE-2007-1255


Published: 2007-03-03   Modified: 2012-02-12

Description:
Unrestricted file upload vulnerability in admin.bbcode.php in Connectix Boards 0.7 and earlier allows remote authenticated administrators to execute arbitrary PHP code by uploading a crafted GIF smiley image with a .php extension via the uploadimage parameter to admin.php, which can be later accessed via a direct request for the file in smileys/. NOTE: this can be leveraged with a separate SQL injection issue for remote unauthenticated attacks.

See advisories in our WLB2 database:
Topic
Author
Date
Med.
Connectix Boards <= 0.7 (p_skin) Multiple Vulnerabilities Exploit
DarkFig
09.03.2007

Type:

CWE-Other

CVSS2 => (AV:N/AC:M/Au:S/C:P/I:P/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
6/10
6.4/10
6.8/10
Exploit range
Attack complexity
Authentication
Remote
Medium
Single time
Confidentiality impact
Integrity impact
Availability impact
Partial
Partial
Partial
Affected software
Connectix -> Connectix boards 

 References:
http://securityreason.com/securityalert/2364
http://www.securityfocus.com/archive/1/460947/100/0/threaded
https://www.exploit-db.com/exploits/3352

Copyright 2022, cxsecurity.com

 

Back to Top