Vulnerability CVE-2007-4822


Published: 2007-09-11   Modified: 2012-02-12

Description:
Cross-site request forgery (CSRF) vulnerability in the device management interface in Buffalo AirStation WHR-G54S 1.20 allows remote attackers to make configuration changes as an administrator via HTTP requests to certain HTML pages in the res parameter with an inp req parameter to cgi-bin/cgi, as demonstrated by accessing (1) ap.html and (2) filter_ip.html.

See advisories in our WLB2 database:
Topic
Author
Date
Low
Buffalo AirStation WHR-G54S CSRF vulnerability
Henri Lindberg
12.09.2007

Type:

CWE-352

(Cross-Site Request Forgery (CSRF))

CVSS2 => (AV:N/AC:M/Au:N/C:N/I:P/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
4.3/10
2.9/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
None
Partial
None
Affected software
Buffalotech -> Airstation whr-g54s 

 References:
http://securityreason.com/securityalert/3117
http://www.louhi.fi/advisory/buffalo_070907.txt
http://www.securityfocus.com/archive/1/478795/100/0/threaded
http://www.securityfocus.com/archive/1/478801/100/0/threaded
http://www.securityfocus.com/bid/25588
https://exchange.xforce.ibmcloud.com/vulnerabilities/36492

Copyright 2020, cxsecurity.com

 

Back to Top