Vulnerability CVE-2008-1035


Published: 2008-06-03   Modified: 2012-02-12

Description:
Use-after-free vulnerability in Apple iCal 3.0.1 on Mac OS X allows remote CalDAV servers, and user-assisted remote attackers, to trigger memory corruption or possibly execute arbitrary code via an "ATTACH;VALUE=URI:S=osumi" line in a .ics file, which triggers a "resource liberation" bug. NOTE: CVE-2008-2007 was originally used for this issue, but this is the appropriate identifier.

See advisories in our WLB2 database:
Topic
Author
Date
Med.
Multiple vulnerabilities in iCal
Core Security Te...
22.05.2008

Type:

CWE-94

(Improper Control of Generation of Code ('Code Injection'))

CVSS2 => (AV:N/AC:M/Au:N/C:N/I:N/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
4.3/10
2.9/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
None
None
Partial
Affected software
Apple -> ICAL 

 References:
http://lists.apple.com/archives/security-announce/2008//May/msg00001.html
http://www.coresecurity.com/?action=item&id=2219
http://www.securityfocus.com/archive/1/492414/100/0/threaded
http://www.securityfocus.com/archive/1/492638/100/100/threaded
http://www.securityfocus.com/archive/1/492682/100/0/threaded
http://www.securityfocus.com/bid/28633
http://www.securityfocus.com/bid/29412
http://www.securityfocus.com/bid/29486
http://www.securitytracker.com/id?1020095
http://www.us-cert.gov/cas/techalerts/TA08-150A.html
http://www.vupen.com/english/advisories/2008/1601
http://www.vupen.com/english/advisories/2008/1697

Copyright 2022, cxsecurity.com

 

Back to Top