Vulnerability CVE-2008-2468


Published: 2008-09-18   Modified: 2012-02-12

Description:
Multiple buffer overflows in the QIP Server Service (aka qipsrvr.exe) in LANDesk Management Suite, Security Suite, and Server Manager 8.8 and earlier allow remote attackers to execute arbitrary code via a crafted heal request, related to the StringToMap and StringSize arguments.

See advisories in our WLB2 database:
Topic
Author
Date
High
Landesk QIP Server Service Heal Packet Buffer Overflow
Aaron Portnoy
22.09.2008

Type:

CWE-119

(Improper Restriction of Operations within the Bounds of a Memory Buffer)

CVSS2 => (AV:N/AC:L/Au:N/C:C/I:C/A:C)

CVSS Base Score
Impact Subscore
Exploitability Subscore
10/10
10/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Complete
Complete
Complete
Affected software
Landesk -> Landesk management suite 
Landesk -> Landesk security suite 
Landesk -> Landesk server manager 

 References:
http://community.landesk.com/support/docs/DOC-3276
http://dvlabs.tippingpoint.com/advisory/TPTI-08-06
http://securityreason.com/securityalert/4269
http://www.kb.cert.org/vuls/id/538011
http://www.securityfocus.com/archive/1/496369/100/0/threaded
http://www.securityfocus.com/bid/31193
http://www.securitytracker.com/id?1020888
http://www.vupen.com/english/advisories/2008/2588
https://exchange.xforce.ibmcloud.com/vulnerabilities/45154

Copyright 2022, cxsecurity.com

 

Back to Top