Vulnerability CVE-2009-0136


Published: 2009-01-16   Modified: 2012-02-13

Description:
Multiple array index errors in the Audible::Tag::readTag function in metadata/audible/audibletag.cpp in Amarok 1.4.10 through 2.0.1 allow remote attackers to cause a denial of service (application crash) or execute arbitrary code via an Audible Audio (.aa) file with a crafted (1) nlen or (2) vlen Tag value, each of which can lead to an invalid pointer dereference, or the writing of a 0x00 byte to an arbitrary memory location, after an allocation failure.

See advisories in our WLB2 database:
Topic
Author
Date
High
Amarok Integer Overflow and Unchecked Allocation Vulnerabilities
Tobias Klein
19.01.2009

Type:

CWE-189

(Numeric Errors)

Vendor: Amarok
Product: Amarok 
Version:
2.0.1
2.0
1.4.10

CVSS2 => (AV:N/AC:M/Au:N/C:C/I:C/A:C)

CVSS Base Score
Impact Subscore
Exploitability Subscore
9.3/10
10/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
Complete
Complete
Complete

 References:
http://amarok.kde.org/en/releases/2.0.1.1
http://bugs.gentoo.org/show_bug.cgi?id=254896
http://lists.opensuse.org/opensuse-security-announce/2009-02/msg00000.html
http://openwall.com/lists/oss-security/2009/01/14/2
http://security.gentoo.org/glsa/glsa-200903-34.xml
http://securityreason.com/securityalert/4915
http://trapkit.de/advisories/TKADV2009-002.txt
http://websvn.kde.org/?view=rev&revision=908391
http://websvn.kde.org/?view=rev&revision=908401
http://websvn.kde.org/?view=rev&revision=908415
http://www.debian.org/security/2009/dsa-1706
http://www.mandriva.com/security/advisories?name=MDVSA-2009:030
http://www.securityfocus.com/archive/1/499984/100/0/threaded
http://www.securityfocus.com/bid/33210
http://www.securitytracker.com/id?1021558
http://www.ubuntu.com/usn/USN-739-1
http://www.vupen.com/english/advisories/2009/0100
https://bugzilla.redhat.com/show_bug.cgi?id=479560
https://bugzilla.redhat.com/show_bug.cgi?id=479946
https://www.redhat.com/archives/fedora-package-announce/2009-January/msg00708.html

Related CVE
CVE-2009-0135
Multiple integer overflows in the Audible::Tag::readTag function in metadata/audible/audibletag.cpp in Amarok 1.4.10 through 2.0.1 allow remote attackers to execute arbitrary code via an Audible Audio (.aa) file with a large (1) nlen or (2) vlen Tag ...
CVE-2008-3699
The MagnatuneBrowser::listDownloadComplete function in magnatunebrowser/magnatunebrowser.cpp in Amarok before 1.4.10 allows local users to overwrite arbitrary files via a symlink attack on the album_info.xml temporary file.
CVE-2006-6979
The ruby handlers in the Magnatune component in Amarok do not properly quote text in certain contexts, probably including construction of an unzip command line, which allows attackers to execute arbitrary commands via shell metacharacters.
CVE-2005-2029
amaroK Web Frontend 1.3 stores the globals.inc file under the web root without a .php extension and insufficient access control, which allows remote attackers to obtain the database username and password via a direct request to the file.

Copyright 2019, cxsecurity.com

 

Back to Top