Vulnerability CVE-2009-2898


Published: 2009-10-13   Modified: 2012-02-13

Description:
Cross-site scripting (XSS) vulnerability in the Alerts list feature in the web interface in SpringSource Hyperic HQ 3.2.x before 3.2.6.1, 4.0.x before 4.0.3.1, 4.1.x before 4.1.2.1, and 4.2-beta1; Application Management Suite (AMS) 2.0.0.SR3; and tc Server 6.0.20.B allows remote authenticated users to inject arbitrary web script or HTML via the Description field. NOTE: some of these details are obtained from third party information.

See advisories in our WLB2 database:
Topic
Author
Date
Low
Hyperic HQ - Stored XSS in alerts list
SpringSource Sec...
14.10.2009

Type:

CWE-79

(Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting'))

CVSS2 => (AV:N/AC:M/Au:S/C:N/I:P/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
3.5/10
2.9/10
6.8/10
Exploit range
Attack complexity
Authentication
Remote
Medium
Single time
Confidentiality impact
Integrity impact
Availability impact
None
Partial
None
Affected software
Springsource -> Application management suite 
Springsource -> Hyperic hq 
Springsource -> Tc server 

 References:
http://corelabs.coresecurity.com/index.php?module=Wiki&action=view&type=advisory&name=Hyperic_HQ_Multiple_XSS
http://jira.hyperic.com/browse/HHQ-3390
http://www.coresecurity.com/content/hyperic-hq-vulnerabilities
http://www.securityfocus.com/archive/1/506935/100/0/threaded
http://www.securityfocus.com/archive/1/506950/100/0/threaded
http://www.springsource.com/security/hyperic-hq
https://exchange.xforce.ibmcloud.com/vulnerabilities/53660

Copyright 2020, cxsecurity.com

 

Back to Top