Vulnerability CVE-2009-4043


Published: 2009-11-20   Modified: 2012-02-13

Description:
Cross-site scripting (XSS) vulnerability in the AddToAny module 5.x before 5.x-2.4 and 6.x before 6.x-2.4 for Drupal allows remote attackers to inject arbitrary web script or HTML via a node title.

Type:

CWE-79

(Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting'))

CVSS2 => (AV:N/AC:M/Au:N/C:N/I:P/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
4.3/10
2.9/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
None
Partial
None
Affected software
Patrick przybilla -> Addtoany 

 References:
http://www.vupen.com/english/advisories/2009/3211
http://drupal.org/node/630208
http://drupal.org/node/630198
http://drupal.org/node/601110
http://xforce.iss.net/xforce/xfdb/54247
http://www.securityfocus.com/bid/36999
http://secunia.com/advisories/37353
http://osvdb.org/59913

Copyright 2020, cxsecurity.com

 

Back to Top