Vulnerability CVE-2009-4494


Published: 2010-01-13   Modified: 2012-02-13

Description:
AOLserver 4.5.1 writes data to a log file without sanitizing non-printable characters, which might allow remote attackers to modify a window's title, or possibly execute arbitrary commands or overwrite files, via an HTTP request containing an escape sequence for a terminal emulator.

See advisories in our WLB2 database:
Topic
Author
Date
Med.
Nginx, Varnish, Cherokee, thttpd, mini-httpd, WEBrick, Orion, AOLserver, Yaws and Boa log escape sequence injection
ascii
17.01.2010

Type:

CWE-20

(Improper Input Validation)

CVSS2 => (AV:N/AC:L/Au:N/C:P/I:N/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
5/10
2.9/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
None
None
Affected software
AOL -> Aolserver 

 References:
http://www.securityfocus.com/archive/1/508830/100/0/threaded
http://www.securityfocus.com/bid/37712
http://www.ush.it/team/ush/hack_httpd_escape/adv.txt

Copyright 2020, cxsecurity.com

 

Back to Top