Vulnerability CVE-2009-4897


Published: 2010-07-22   Modified: 2012-02-13

Description:
Buffer overflow in gs/psi/iscan.c in Ghostscript 8.64 and earlier allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted PDF document containing a long name.

Type:

CWE-119

(Improper Restriction of Operations within the Bounds of a Memory Buffer)

CVSS2 => (AV:N/AC:M/Au:N/C:C/I:C/A:C)

CVSS Base Score
Impact Subscore
Exploitability Subscore
9.3/10
10/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
Complete
Complete
Complete
Affected software
Artifex -> Afpl ghostscript 
Artifex -> Ghostscript fonts 
Artifex -> Gpl ghostscript 

 References:
http://www.securityfocus.com/bid/41593
https://bugzilla.redhat.com/show_bug.cgi?id=613792
http://xforce.iss.net/xforce/xfdb/60380
http://www.ubuntu.com/usn/USN-961-1
http://www.osvdb.org/66277
http://www.mandriva.com/security/advisories?name=MDVSA-2010:135
http://www.mandriva.com/security/advisories?name=MDVSA-2010:134
http://security.gentoo.org/glsa/glsa-201412-17.xml
http://secunia.com/advisories/40580
http://bugs.ghostscript.com/show_bug.cgi?id=690523

Copyright 2021, cxsecurity.com

 

Back to Top