Vulnerability CVE-2009-4939


Published: 2010-07-22   Modified: 2012-02-13

Description:
Multiple cross-site scripting (XSS) vulnerabilities in index.php in AdPeeps 8.5d1 allow remote attackers to inject arbitrary web script or HTML via the (1) uid parameter, (2) uid parameter in a login_lookup action, (3) uid parameter in an adminlogin action, (4) campaignid parameter in a createcampaign action, (5) type parameter in a view_account_stats action, (6) period parameter in a view_account_stats action, (7) uid parameter in a view_adrates action, (8) accname parameter in an account_confirmation action, (9) loginpass parameter in an account_confirmation action, (10) e9 parameter in a setup_account action, (11) from parameter in an email_advertisers action, (12) message parameter in an email_advertisers action, (13) idno parameter in an edit_ad_package action, (14) Advertiser Name field, (15) First Name field, (16) Last Name field, (17) Address field, (18) Phone Number field, (19) Password Hint field, or (20) URL field; and (21) allow remote authenticated users to inject arbitrary web script or HTML via an unspecified form associated with a view_adrates action.

See advisories in our WLB2 database:
Topic
Author
Date
High
AdPeeps 8.5d1 - XSS and HTML Injection Vulnerabilities
MaXe
22.07.2010

Type:

CWE-79

(Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting'))

Vendor: Impactsoftcompany
Product: Adpeeps 
Version: 8.5;

CVSS2 => (AV:N/AC:M/Au:N/C:N/I:P/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
4.3/10
2.9/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
None
Partial
None

 References:
http://forum.intern0t.net/exploits-vulnerabilities-pocs/1049-intern0t-adpeeps-8-5d1-cross-site-scripting-html-injection-vulnerabilities.html
http://www.exploit-db.com/exploits/8818
http://www.securityfocus.com/archive/1/503855/100/0/threaded
http://www.securityfocus.com/archive/1/503911/100/0/threaded
https://exchange.xforce.ibmcloud.com/vulnerabilities/50823
https://exchange.xforce.ibmcloud.com/vulnerabilities/50824

Copyright 2019, cxsecurity.com

 

Back to Top