Vulnerability CVE-2010-4819


Published: 2012-09-05   Modified: 2012-09-06

Description:
The ProcRenderAddGlyphs function in the Render extension (render/render.c) in X.Org xserver 1.7.7 and earlier allows local users to read arbitrary memory and possibly cause a denial of service (server crash) via unspecified vectors related to an "input sanitization flaw."

Type:

CWE-20

(Improper Input Validation)

CVSS2 => (AV:L/AC:L/Au:N/C:P/I:N/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
3.6/10
4.9/10
3.9/10
Exploit range
Attack complexity
Authentication
Local
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
None
Partial
Affected software
X -> X.org-xserver 

 References:
https://bugs.freedesktop.org/show_bug.cgi?id=28801
http://www.openwall.com/lists/oss-security/2011/09/23/5
http://www.openwall.com/lists/oss-security/2011/09/22/8
http://securitytracker.com/id?1026149
http://rhn.redhat.com/errata/RHSA-2011-1360.html
http://rhn.redhat.com/errata/RHSA-2011-1359.html
http://cgit.freedesktop.org/xorg/xserver/commit/render/render.c?id=5725849a1b427cd4a72b84e57f211edb35838718
http://aix.software.ibm.com/aix/efixes/security/X_advisory2.asc

Copyright 2022, cxsecurity.com

 

Back to Top