Vulnerability CVE-2011-1842


Published: 2011-05-02   Modified: 2012-02-13

Description:
dbus_backend/lsd.py in the D-Bus backend in language-selector before 0.6.7 does not validate the arguments to the (1) SetSystemDefaultLangEnv and (2) SetSystemDefaultLanguageEnv functions, which allows local users to gain privileges via shell metacharacters in a string argument, a different vulnerability than CVE-2011-0729.

Type:

CWE-20

(Improper Input Validation)

CVSS2 => (AV:L/AC:L/Au:N/C:C/I:C/A:C)

CVSS Base Score
Impact Subscore
Exploitability Subscore
7.2/10
10/10
3.9/10
Exploit range
Attack complexity
Authentication
Local
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Complete
Complete
Complete
Affected software
Ubuntu -> Language-selector 

 References:
https://launchpad.net/bugs/764397
http://www.securityfocus.com/bid/47502
https://launchpad.net/ubuntu/+source/language-selector/0.6.7
http://xforce.iss.net/xforce/xfdb/67255
http://www.vupen.com/english/advisories/2011/1032
http://www.ubuntuupdates.org/packages/show/307975
http://www.ubuntu.com/usn/USN-1115-1/
http://secunia.com/advisories/44214

Copyright 2022, cxsecurity.com

 

Back to Top