Vulnerability CVE-2012-0177


Published: 2012-04-10

Description:
Heap-based buffer overflow in the Office Works File Converter in Microsoft Office 2007 SP2, Works 9, and Works 6-9 File Converter allows remote attackers to execute arbitrary code via a crafted Works (aka .wps) file, aka "Office WPS Converter Heap Overflow Vulnerability."

Type:

CWE-119

(Improper Restriction of Operations within the Bounds of a Memory Buffer)

CVSS2 => (AV:N/AC:M/Au:N/C:C/I:C/A:C)

CVSS Base Score
Impact Subscore
Exploitability Subscore
9.3/10
10/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
Complete
Complete
Complete
Affected software
Microsoft -> Office 
Microsoft -> Works 
Microsoft -> Works 6-9 file converter 

 References:
http://www.securityfocus.com/bid/52867
http://www.securitytracker.com/id?1026910
http://www.securitytracker.com/id?1026911
http://www.us-cert.gov/cas/techalerts/TA12-101A.html
https://docs.microsoft.com/en-us/security-updates/securitybulletins/2012/ms12-028
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A15598

Copyright 2020, cxsecurity.com

 

Back to Top