Vulnerability CVE-2012-2055


Published: 2012-04-05

Description:
GitHub Enterprise before 20120304 does not properly restrict the use of a hash to provide values for a model's attributes, which allows remote attackers to set the public_key[user_id] value via a modified URL for the public-key update form, related to a "mass assignment" vulnerability.

Type:

CWE-255

(Credentials Management)

CVSS2 => (AV:N/AC:L/Au:N/C:N/I:P/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
5/10
2.9/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
None
Partial
None
Affected software
Github -> Github enterprise 

 References:
http://homakov.blogspot.com/2012/03/how-to.html
http://lwn.net/Articles/488702/
https://exchange.xforce.ibmcloud.com/vulnerabilities/74812
https://github.com/blog/1068-public-key-security-vulnerability-and-mitigation

Copyright 2022, cxsecurity.com

 

Back to Top