Vulnerability CVE-2012-2707


Published: 2012-06-26   Modified: 2012-06-27

Description:
The Hostmaster (Aegir) module 6.x-1.x before 6.x-1.9 for Drupal does not properly exit when users do not have access to package/task nodes, which allows remote attackers to bypass intended access restrictions and edit unauthorized nodes.

See advisories in our WLB2 database:
Topic
Author
Date
High
Drupal Hostmaster 6.x Cross Site Scripting / Access Bypass
Steven Jones and...
17.05.2012

Type:

CWE-264

(Permissions, Privileges, and Access Controls)

CVSS2 => (AV:N/AC:M/Au:N/C:N/I:P/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
5.8/10
4.9/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
None
Partial
Partial
Affected software
Antoine beaupre -> Hostmaster 

 References:
http://drupalcode.org/project/hostmaster.git/commitdiff/8a61101
http://drupal.org/node/1585658
http://www.securityfocus.com/bid/53588
http://www.openwall.com/lists/oss-security/2012/06/14/3
http://drupal.org/node/1585678
http://community.aegirproject.org/1.9

Copyright 2021, cxsecurity.com

 

Back to Top