Vulnerability CVE-2015-1803


Published: 2015-03-20

Description:
The bdfReadCharacters function in bitmap/bdfread.c in X.Org libXfont before 1.4.9 and 1.5.x before 1.5.1 does not properly handle character bitmaps it cannot read, which allows remote authenticated users to cause a denial of service (NULL pointer dereference and crash) and possibly execute arbitrary code via a crafted BDF font file.

CVSS2 => (AV:N/AC:M/Au:S/C:C/I:C/A:C)

CVSS Base Score
Impact Subscore
Exploitability Subscore
8.5/10
10/10
6.8/10
Exploit range
Attack complexity
Authentication
Remote
Medium
Single time
Confidentiality impact
Integrity impact
Availability impact
Complete
Complete
Complete
Affected software
X -> Libxfont 
Debian -> Debian linux 
Canonical -> Ubuntu linux 

 References:
http://advisories.mageia.org/MGASA-2015-0113.html
http://lists.fedoraproject.org/pipermail/package-announce/2015-March/152497.html
http://lists.fedoraproject.org/pipermail/package-announce/2015-March/152838.html
http://lists.opensuse.org/opensuse-security-announce/2015-03/msg00032.html
http://lists.opensuse.org/opensuse-security-announce/2015-04/msg00002.html
http://lists.opensuse.org/opensuse-security-announce/2015-04/msg00005.html
http://rhn.redhat.com/errata/RHSA-2015-1708.html
http://www.debian.org/security/2015/dsa-3194
http://www.mandriva.com/security/advisories?name=MDVSA-2015:145
http://www.oracle.com/technetwork/topics/security/bulletinapr2015-2511959.html
http://www.oracle.com/technetwork/topics/security/cpujul2015-2367936.html
http://www.securityfocus.com/bid/73280
http://www.securitytracker.com/id/1031935
http://www.ubuntu.com/usn/USN-2536-1
http://www.x.org/wiki/Development/Security/Advisory-2015-03-17/
https://security.gentoo.org/glsa/201507-21

Copyright 2022, cxsecurity.com

 

Back to Top