Vulnerability CVE-2015-1859


Published: 2015-05-12

Description:
Multiple buffer overflows in plugins/imageformats/ico/qicohandler.cpp in the QtBase module in Qt before 4.8.7 and 5.x before 5.4.2 allow remote attackers to cause a denial of service (segmentation fault and crash) and possibly execute arbitrary code via a crafted ICO image.

CVSS2 => (AV:N/AC:M/Au:N/C:P/I:P/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
6.8/10
6.4/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
Partial
Partial
Affected software
Fedoraproject -> Fedora 
Digia -> QT 

 References:
http://lists.fedoraproject.org/pipermail/package-announce/2015-April/155424.html
http://lists.fedoraproject.org/pipermail/package-announce/2015-April/155927.html
http://lists.fedoraproject.org/pipermail/package-announce/2015-April/155962.html
http://lists.fedoraproject.org/pipermail/package-announce/2015-April/155976.html
http://lists.fedoraproject.org/pipermail/package-announce/2015-April/156727.html
http://lists.qt-project.org/pipermail/announce/2015-April/000067.html
http://www.securityfocus.com/bid/74307
http://www.securityfocus.com/bid/74310
http://www.ubuntu.com/usn/USN-2626-1
https://security.gentoo.org/glsa/201603-10

Copyright 2022, cxsecurity.com

 

Back to Top