Vulnerability CVE-2015-4456


Published: 2015-10-26

Description:
ownCloud Desktop Client before 1.8.2 does not call QNetworkReply::ignoreSslErrors with the list of errors to be ignored, which allows man-in-the-middle attackers to bypass the user's certificate distrust decision and obtain sensitive information by leveraging a self-signed certificate and a connection to a server using its own self-signed certificate.

CVSS2 => (AV:N/AC:H/Au:N/C:P/I:N/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
2.6/10
2.9/10
4.9/10
Exploit range
Attack complexity
Authentication
Remote
High
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
None
None
Affected software
Owncloud -> Owncloud desktop client 

 References:
http://www.debian.org/security/2015/dsa-3363
http://www.securityfocus.com/bid/75354
https://github.com/owncloud/client/issues/3283
https://owncloud.org/security/advisory/?id=oc-sa-2015-009

Copyright 2022, cxsecurity.com

 

Back to Top