Vulnerability CVE-2016-6131


Published: 2017-02-07

Description:
The demangler in GNU Libiberty allows remote attackers to cause a denial of service (infinite loop, stack overflow, and crash) via a cycle in the references of remembered mangled types.

CVSS2 => (AV:N/AC:L/Au:N/C:N/I:N/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
5/10
2.9/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
None
None
Partial
Affected software
GNU -> Libiberty 

 References:
http://www.openwall.com/lists/oss-security/2016/06/30/4
http://www.openwall.com/lists/oss-security/2016/06/30/7
http://www.securityfocus.com/bid/91519
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=71696
https://gcc.gnu.org/ml/gcc-patches/2016-06/msg02030.html

Copyright 2021, cxsecurity.com

 

Back to Top