Vulnerability CVE-2016-7420


Published: 2016-09-16

Description:
Crypto++ (aka cryptopp) through 5.6.4 does not document the requirement for a compile-time NDEBUG definition disabling the many assert calls that are unintended in production use, which might allow context-dependent attackers to obtain sensitive information by leveraging access to process memory after an assertion failure, as demonstrated by reading a core dump.

CVSS2 => (AV:N/AC:M/Au:N/C:P/I:N/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
4.3/10
2.9/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
None
None
Affected software
Cryptopp -> Crypto++ 

 References:
http://www.openwall.com/lists/oss-security/2016/09/15/12
http://www.openwall.com/lists/oss-security/2016/09/16/1
https://github.com/weidai11/cryptopp/commit/553049ba297d89d9e8fbf2204acb40a8a53f5cd6
https://github.com/weidai11/cryptopp/issues/277

Copyright 2022, cxsecurity.com

 

Back to Top