Vulnerability CVE-2016-9814


Published: 2017-02-16   Modified: 2017-02-17

Description:
The validateSignature method in the SAML2\Utils class in SimpleSAMLphp before 1.14.10 and simplesamlphp/saml2 library before 1.9.1, 1.10.x before 1.10.3, and 2.x before 2.3.3 allows remote attackers to spoof SAML responses or possibly cause a denial of service (memory consumption) by leveraging improper conversion of return values to boolean.

Type:

CWE-399

(Resource Management Errors)

CVSS2 => (AV:N/AC:L/Au:N/C:N/I:P/A:C)

CVSS Base Score
Impact Subscore
Exploitability Subscore
8.5/10
7.8/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
None
Partial
Complete
Affected software
Simplesamlphp -> Saml2 
Simplesamlphp -> Simplesamlphp 

 References:
http://www.securityfocus.com/bid/94730
https://lists.debian.org/debian-lts-announce/2018/03/msg00001.html
https://simplesamlphp.org/security/201612-01

Copyright 2022, cxsecurity.com

 

Back to Top