Vulnerability CVE-2017-17382


Published: 2017-12-13

Description:
Citrix NetScaler Application Delivery Controller (ADC) and NetScaler Gateway 10.5 before build 67.13, 11.0 before build 71.22, 11.1 before build 56.19, and 12.0 before build 53.22 might allow remote attackers to decrypt TLS ciphertext data by leveraging a Bleichenbacher RSA padding oracle, aka a ROBOT attack.

Type:

CWE-327

(Use of a Broken or Risky Cryptographic Algorithm)

CVSS2 => (AV:N/AC:M/Au:N/C:P/I:N/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
4.3/10
2.9/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
None
None
Affected software
Citrix -> Application delivery controller firmware 
Citrix -> Netscaler gateway firmware 

 References:
http://www.securityfocus.com/bid/102173
http://www.securitytracker.com/id/1039985
https://robotattack.org/
https://support.citrix.com/article/ctx230238
https://www.kb.cert.org/vuls/id/144389

Copyright 2020, cxsecurity.com

 

Back to Top