Vulnerability CVE-2017-17758


Published: 2017-12-19

Description:
TP-Link TL-WVR and TL-WAR devices allow remote authenticated users to execute arbitrary commands via shell metacharacters in the interface field of an admin/dhcps command to cgi-bin/luci, related to the zone_get_iface_bydev function in /usr/lib/lua/luci/controller/admin/dhcps.lua in uhttpd.

Type:

CWE-78

(Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') )

CVSS2 => (AV:N/AC:L/Au:S/C:C/I:C/A:C)

CVSS Base Score
Impact Subscore
Exploitability Subscore
9/10
10/10
8/10
Exploit range
Attack complexity
Authentication
Remote
Low
Single time
Confidentiality impact
Integrity impact
Availability impact
Complete
Complete
Complete
Affected software
Tp-link -> Tl-war1200l firmware 
Tp-link -> Tl-war1300l firmware 
Tp-link -> Tl-war1750l firmware 
Tp-link -> Tl-war2600l firmware 
Tp-link -> Tl-war450l firmware 
Tp-link -> Tl-war458l firmware 
Tp-link -> Tl-war900l firmware 
Tp-link -> Tl-wvr1200l firmware 
Tp-link -> Tl-wvr1300l firmware 
Tp-link -> Tl-wvr1750l firmware 
Tp-link -> Tl-wvr2600l firmware 
Tp-link -> Tl-wvr4300l firmware 
Tp-link -> Tl-wvr450l firmware 
Tp-link -> Tl-wvr458l firmware 
Tp-link -> Tl-wvr900l firmware 

 References:
https://github.com/L1ZhaoXin/Router-Vulnerability-Research/blob/master/Tplink_LUCI_Dhcps_Authenticated_RCE_Record.txt

Copyright 2020, cxsecurity.com

 

Back to Top