Vulnerability CVE-2017-18082


Published: 2018-02-02

Description:
The plan configure branches resource in Atlassian Bamboo before version 6.2.3 allows remote attackers to inject arbitrary HTML or JavaScript via a cross site scripting (XSS) vulnerability through the name of a branch.

Type:

CWE-79

(Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting'))

Vendor: Atlassian
Product: Bamboo 
Version:
5.9.7
5.9.4
5.9.3
5.9.2
5.9.1
5.9
5.8.5
5.8.2
5.8.1
5.8
5.7.2
5.7.1
5.7
5.6.2
5.6.1
5.6
5.5
5.4.2
5.4.1
5.4
5.3
5.2.2
5.2.1
5.2
5.14.5
5.14.4.1
5.14.3
5.14.2
5.14.1
5.14.0
5.13.2
5.13.1
5.13.0
5.12.5
5.12.4
5.12.2
5.12.1
5.12.0
5.11.3
5.1.1
5.1
5.0.1
5.0
4.4.8
4.4.5
4.4.4
4.4.3
4.4.2
4.4.1
4.4
4.3.4
4.3.3
4.3.2
4.3.1
4.3
4.2.1
4.2
4.1.2
4.1.1
4.1
4.0.1
4.0
3.4.5
3.4.4
3.4.3
3.4.2
3.4.1
3.4
3.3.4
3.3.3
3.3.2
3.3.1
3.3
3.2.2
3.2
3.1.4
3.1.3
3.1.1
3.1
3.0.3
3.0.2
3.0.1
3.0
2.7.4
2.7.3
2.7.2
2.7.1
2.7
2.6.3
2.6.2
2.6.1
2.6
2.5.5
2.5.3
2.5.2
2.5.1
2.5
2.4.3
2.4.2
2.4.1
See more versions on NVD

CVSS2 => (AV:N/AC:M/Au:S/C:N/I:P/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
3.5/10
2.9/10
6.8/10
Exploit range
Attack complexity
Authentication
Remote
Medium
Single time
Confidentiality impact
Integrity impact
Availability impact
None
Partial
None

 References:
https://jira.atlassian.com/browse/BAM-19666

Related CVE
CVE-2017-18110
The administration backup restore resource in Atlassian Crowd before version 3.0.2 and from version 3.1.0 before version 3.1.1 allows remote attackers to read files from the filesystem via a XXE vulnerability.
CVE-2017-18109
The login resource of CrowdId in Atlassian Crowd before version 3.0.2 and from version 3.1.0 before version 3.1.1 allows remote attackers to redirect users to a different website which they may use as part of performing a phishing attack via an open ...
CVE-2017-18108
The administration SMTP configuration resource in Atlassian Crowd before version 2.10.2 allows remote attackers with administration rights to execute arbitrary code via a JNDI injection.
CVE-2017-18106
The identifier_hash for a session token in Atlassian Crowd before version 2.9.1 could potentially collide with an identifier_hash for another user or a user in a different directory, this allows remote attackers who can authenticate to Crowd or an ap...
CVE-2017-18105
The console login resource in Atlassian Crowd before version 3.0.2 and from version 3.1.0 before version 3.1.1 allows remote attackers, who have previously obtained a user's JSESSIONID cookie, to gain access to some of the built-in and potentially th...
CVE-2019-3396
The Widget Connector macro in Atlassian Confluence Server before version 6.6.12 (the fixed version for 6.6.x), from version 6.7.0 before 6.12.3 (the fixed version for 6.12.x), from version 6.13.0 before 6.13.3 (the fixed version for 6.13.x), and from...
CVE-2019-3395
The WebDAV endpoint in Atlassian Confluence Server and Data Center before version 6.6.7 (the fixed version for 6.6.x), from version 6.7.0 before 6.8.5 (the fixed version for 6.8.x), and from version 6.9.0 before 6.9.3 (the fixed version for 6.9.x) al...
CVE-2018-20236
There was an command injection vulnerability in Sourcetree for Windows from version 0.5a before version 3.0.10 via URI handling. A remote attacker could send a malicious URI to a victim using Sourcetree for Windows to exploit this issue to gain code ...

Copyright 2019, cxsecurity.com

 

Back to Top