Vulnerability CVE-2017-6836


Published: 2017-03-20

Description:
Heap-based buffer overflow in the Expand3To4Module::run function in libaudiofile/modules/SimpleModule.h in Audio File Library (aka audiofile) 0.3.6 allows remote attackers to cause a denial of service (crash) via a crafted file.

Type:

CWE-119

(Improper Restriction of Operations within the Bounds of a Memory Buffer)

CVSS2 => (AV:N/AC:M/Au:N/C:N/I:N/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
4.3/10
2.9/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
None
None
Partial
Affected software
Audiofile -> Audiofile 

 References:
http://www.debian.org/security/2017/dsa-3814
http://www.openwall.com/lists/oss-security/2017/03/13/8
https://blogs.gentoo.org/ago/2017/02/20/audiofile-heap-based-buffer-overflow-in-expand3to4modulerun-simplemodule-h/
https://github.com/mpruett/audiofile/issues/40
https://github.com/mpruett/audiofile/pull/42

Copyright 2021, cxsecurity.com

 

Back to Top