Vulnerability CVE-2018-1000168


Published: 2018-05-08

Description:
nghttp2 version >= 1.10.0 and nghttp2 <= v1.31.0 contains an Improper Input Validation CWE-20 vulnerability in ALTSVC frame handling that can result in segmentation fault leading to denial of service. This attack appears to be exploitable via network client. This vulnerability appears to have been fixed in >= 1.31.1.

Type:

CWE-476

(NULL Pointer Dereference)

Vendor: Nodejs
Product: Node.js 
Version:
9.9.0
9.8.0
9.7.1
9.7.0
9.6.1
9.6.0
9.5.0
9.4.0
9.3.0
9.2.1
9.2.0
9.11.2
9.11.1
9.11.0
9.10.1
9.10.0
9.1.0
9.0.0
8.9.4
8.9.3
8.9.2
8.9.1
8.9.0
8.8.1
8.8.0
8.7.0
8.6.0
8.5.0
8.4.0
8.15.1
8.15.0
8.14.1
8.14.0
8.13.0
8.12.0
8.11.4
8.11.3
8.11.2
8.11.1
8.11.0
8.10.0
10.9.0
10.8.0
10.7.0
10.6.0
10.5.0
10.4.1
10.4.0
10.3.0
10.2.1
10.2.0
10.15.2
10.15.1
10.15.0
10.14.2
10.14.1
10.14.0
10.13.0
10.12.0
10.11.0
10.10.0
10.1.0
10.0.0
Vendor: Nghttp2
Product: Nghttp2 
Version:
1.31.0
1.30.0
1.29.0
1.28.0
1.27.0
1.26.0
1.25.0
1.24.0
1.23.1
1.23.0
1.22.0
1.21.1
1.21.0
1.20.0
1.19.0
1.18.1
1.18.0
1.17.0
1.16.1
1.16.0
1.15.0
1.14.1
1.14.0
1.13.0
1.12.0
1.11.1
1.11.0
1.10.0

CVSS2 => (AV:N/AC:L/Au:N/C:N/I:N/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
5/10
2.9/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
None
None
Partial

 References:
http://www.securityfocus.com/bid/103952
https://access.redhat.com/errata/RHSA-2019:0366
https://access.redhat.com/errata/RHSA-2019:0367
https://nghttp2.org/blog/2018/04/12/nghttp2-v1-31-1/
https://nodejs.org/en/blog/vulnerability/june-2018-security-releases/

Copyright 2019, cxsecurity.com

 

Back to Top