Vulnerability CVE-2018-12015


Published: 2018-06-07

Description:
In Perl through 5.26.2, the Archive::Tar module allows remote attackers to bypass a directory-traversal protection mechanism, and overwrite arbitrary files, via an archive file containing a symlink and a regular file with the same name.

Type:

CWE-22

(Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal'))

Vendor: Debian
Product: Debian linux 
Version: 9.0; 8.0;
Vendor: PERL
Product: PERL 
Version: 5.26.2;
Vendor: Canonical
Product: Ubuntu linux 
Version:
18.04
17.10
16.04
14.04
12.04
See more versions on NVD
Vendor: Apple
Product: Mac os x 
Version:
10.9.5
10.9.4
10.9.3
10.9.2
10.9.1
10.9
10.8.5
10.8.4
10.8.3
10.8.2
10.8.1
10.8.0
10.7.5
10.7.4
10.7.3
10.7.2
10.7.1
10.7.0
10.6.8
10.6.7
10.6.6
10.6.5
10.6.4
10.6.3
10.6.2
10.6.1
10.6.0
10.5.8
10.5.7
10.5.6
10.5.5
10.5.4
10.5.3
10.5.2
10.5.1
10.5.0
10.5
10.4.9
10.4.8
10.4.7
10.4.6
10.4.5
10.4.4
10.4.3
10.4.2
10.4.11
10.4.10
10.4.1
10.4.0
10.4
10.3.9
10.3.8
10.3.7
10.3.6
10.3.5
10.3.4
10.3.3
10.3.2
10.3.1
10.3.0
10.3
10.2.8
10.2.7
10.2.6
10.2.5
10.2.4
10.2.3
10.2.2
10.2.1
10.2.0
10.2
10.13.6
10.13.5
10.13.4
10.13.3
10.13.2
10.13.1
10.13.0
10.13
10.12.6
10.12.5
10.12.4
10.12.3
10.12.2
10.12.1
10.12.0
10.12
10.11.6
10.11.5
10.11.4
10.11.3
10.11.2
See more versions on NVD

CVSS2 => (AV:N/AC:L/Au:N/C:N/I:P/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
6.4/10
4.9/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
None
Partial
Partial

 References:
http://seclists.org/fulldisclosure/2019/Mar/49
http://www.securityfocus.com/bid/104423
http://www.securitytracker.com/id/1041048
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=900834
https://seclists.org/bugtraq/2019/Mar/42
https://security.netapp.com/advisory/ntap-20180927-0001/
https://support.apple.com/kb/HT209600
https://usn.ubuntu.com/3684-1/
https://usn.ubuntu.com/3684-2/
https://www.debian.org/security/2018/dsa-4226

Related CVE
CVE-2018-4470
A privacy issue in the handling of Open Directory records was addressed with improved indexing. This issue affected versions prior to macOS High Sierra 10.13.6.
CVE-2018-4465
A memory corruption issue was addressed with improved memory handling. This issue affected versions prior to iOS 12.1.1, macOS Mojave 10.14.2, tvOS 12.1.1, watchOS 5.1.2.
CVE-2018-4464
Multiple memory corruption issues were addressed with improved memory handling. This issue affected versions prior to iOS 12.1.1, tvOS 12.1.1, watchOS 5.1.2, Safari 12.0.2, iTunes 12.9.2 for Windows, iCloud for Windows 7.9.
CVE-2018-4463
A memory corruption issue was addressed with improved memory handling. This issue affected versions prior to macOS Mojave 10.14.2.
CVE-2018-4462
A validation issue was addressed with improved input sanitization. This issue affected versions prior to macOS Mojave 10.14.2.
CVE-2018-4461
A memory corruption issue was addressed with improved input validation. This issue affected versions prior to iOS 12.1.1, macOS Mojave 10.14.2, tvOS 12.1.1, watchOS 5.1.2.
CVE-2018-4460
A denial of service issue was addressed by removing the vulnerable code. This issue affected versions prior to iOS 12.1.1, macOS Mojave 10.14.2, tvOS 12.1.1, watchOS 5.1.2.
CVE-2018-4456
A memory corruption issue was addressed with improved input validation. This issue affected versions prior to macOS High Sierra 10.13.6, macOS Mojave 10.14.

Copyright 2019, cxsecurity.com

 

Back to Top