Vulnerability CVE-2018-4877


Published: 2018-02-06

Description:
A use-after-free vulnerability was discovered in Adobe Flash Player before 28.0.0.161. This vulnerability occurs due to a dangling pointer in the Primetime SDK related to media player's quality of service functionality. A successful attack can lead to arbitrary code execution.

Type:

CWE-416

(Use After Free)

Vendor: Adobe
Product: Flash player 
Version:
9.125.0
9.0.9.0
9.0.8.0
9.0.48.0
9.0.47.0
9.0.45.0
9.0.31.0
9.0.31
9.0.283.0
9.0.280
9.0.28.0
9.0.28
9.0.277.0
9.0.262.0
9.0.260.0
9.0.246.0
9.0.20.0
9.0.20
9.0.18d60
9.0.16
9.0.159.0
9.0.155.0
9.0.152.0
9.0.151.0
9.0.125.0
9.0.124.0
9.0.115.0
9.0.114.0
9.0.112.0
9.0
8.0.42.0
8.0.39.0
8.0.35.0
8.0.34.0
8.0.33.0
8.0.24.0
8.0.22.0
8.0
7.2
7.1.1
7.1
7.0.73.0
7.0.70.0
7.0.69.0
7.0.68.0
7.0.67.0
7.0.66.0
7.0.63
7.0.61.0
7.0.60.0
7.0.53.0
7.0.25
7.0.24.0
7.0.19.0
7.0.14.0
7.0.1
7.0
6.0.79
6.0.21.0
6
5
4
3
26.0.0.137
24.0.0.221
24.0.0.194
24.0.0.186
23.0.0.207
23.0.0.185
22.0.0.211
22.0.0.192
21.0.0.97
21.0.0.242
21.0.0.226
21.0.0.213
20.0.0.306
20.0.0.286
20.0.0.235
20.0.0.228
2
19.0.0.245
19.0.0.226
19.0.0.207
19.0.0.185
18.0.0.366
18.0.0.360
18.0.0.352
18.0.0.343
18.0.0.333
18.0.0.326
18.0.0.324
18.0.0.268
18.0.0.261
18.0.0.209
See more versions on NVD
Vendor: Redhat
Product: Enterprise linux server 
Version: 6.0;
Product: Enterprise linux desktop 
Version: 6.0;
Product: Enterprise linux workstation 
Version: 6.0;

CVSS2 => (AV:N/AC:L/Au:N/C:C/I:C/A:C)

CVSS Base Score
Impact Subscore
Exploitability Subscore
10/10
10/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Complete
Complete
Complete

 References:
http://www.securityfocus.com/bid/102930
https://access.redhat.com/errata/RHSA-2018:0285
https://helpx.adobe.com/security/products/flash-player/apsb18-03.html

Related CVE
CVE-2016-9603
A heap buffer overflow flaw was found in QEMU's Cirrus CLGD 54xx VGA emulator's VNC display driver support before 2.9; the issue could occur when a VNC client attempted to update its display after a VGA operation is performed by a guest. A privileged...
CVE-2017-7463
JBoss BRMS 6 and BPM Suite 6 before 6.4.3 are vulnerable to a reflected XSS via artifact upload. A malformed XML file, if uploaded, causes an error message to appear that includes part of the bad XML code verbatim without filtering out scripts. Succe...
CVE-2017-2674
JBoss BRMS 6 and BPM Suite 6 before 6.4.3 are vulnerable to a stored XSS via several lists in Business Central. The flaw is due to lack of sanitation of user input when creating new lists. Remote, authenticated attackers that have privileges to creat...
CVE-2017-2620
Quick emulator (QEMU) before 2.8 built with the Cirrus CLGD 54xx VGA Emulator support is vulnerable to an out-of-bounds access issue. The issue could occur while copying VGA data in cirrus_bitblt_cputovideo. A privileged user inside guest could use t...
CVE-2017-2618
A flaw was found in the Linux kernel's handling of clearing SELinux attributes on /proc/pid/attr files before 4.9.10. An empty (null) write to this file can crash the system by causing the system to attempt to access unmapped kernel memory.
CVE-2017-2616
A race condition was found in util-linux before 2.32.1 in the way su handled the management of child processes. A local authenticated attacker could use this flaw to kill other processes with root privileges under specific conditions.
CVE-2017-7509
An input validation error was found in Red Hat Certificate System's handling of client provided certificates before 8.1.20-1. If the certreq field is not present in a certificate an assertion error is triggered causing a denial of service.
CVE-2017-12175
Red Hat Satellite before 6.5 is vulnerable to a XSS in discovery rule when you are entering filter and you use autocomplete functionality.

Copyright 2018, cxsecurity.com

 

Back to Top