Vulnerability CVE-2019-10152


Published: 2019-07-30   Modified: 2019-07-31

Description:
A path traversal vulnerability has been discovered in podman before version 1.4.0 in the way it handles symlinks inside containers. An attacker who has compromised an existing container can cause arbitrary files on the host filesystem to be read/written when an administrator tries to copy a file from/to the container.

Type:

CWE-22

(Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal'))

CVSS2 => (AV:L/AC:H/Au:N/C:P/I:P/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
2.6/10
4.9/10
1.9/10
Exploit range
Attack complexity
Authentication
Local
High
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
Partial
None
Affected software
Libpod project -> Libpod 

 References:
http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00001.html
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10152
https://github.com/containers/libpod/blob/master/RELEASE_NOTES.md#140
https://github.com/containers/libpod/issues/3211
https://github.com/containers/libpod/pull/3214

Copyright 2022, cxsecurity.com

 

Back to Top