Vulnerability CVE-2019-19609


Published: 2019-12-05

Description:
The Strapi framework before 3.0.0-beta.17.8 is vulnerable to Remote Code Execution in the Install and Uninstall Plugin components of the Admin panel, because it does not sanitize the plugin name, and attackers can inject arbitrary shell commands to be executed by the execa function.

See advisories in our WLB2 database:
Topic
Author
Date
High
Strapi 3.0.0-beta.17.7 Remote Code Execution
David Uton
31.08.2021

Type:

CWE-20

(Improper Input Validation)

CVSS2 => (AV:N/AC:L/Au:S/C:C/I:C/A:C)

CVSS Base Score
Impact Subscore
Exploitability Subscore
9/10
10/10
8/10
Exploit range
Attack complexity
Authentication
Remote
Low
Single time
Confidentiality impact
Integrity impact
Availability impact
Complete
Complete
Complete
Affected software
Strapi -> Strapi 

 References:
https://bittherapy.net/post/strapi-framework-remote-code-execution/
https://github.com/strapi/strapi/pull/4636

Copyright 2021, cxsecurity.com

 

Back to Top