Vulnerability CVE-2020-25125


Published: 2020-09-03

Description:
GnuPG 2.2.21 and 2.2.22 (and Gpg4win 3.1.12) has an array overflow, leading to a crash or possibly unspecified other impact, when a victim imports an attacker's OpenPGP key, and this key has AEAD preferences. The overflow is caused by a g10/key-check.c error. NOTE: GnuPG 2.3.x is unaffected. GnuPG 2.2.23 is a fixed version.

Type:

CWE-120

(Buffer Copy without Checking Size of Input ('Classic Buffer Overflow'))

CVSS2 => (AV:N/AC:M/Au:N/C:P/I:P/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
6.8/10
6.4/10
8.6/10
Exploit range
Attack complexity
Authentication
Remote
Medium
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
Partial
Partial
Affected software
Gpg4win -> Gpg4win 
Gnupg -> Gnupg 

 References:
http://www.openwall.com/lists/oss-security/2020/09/03/4
http://www.openwall.com/lists/oss-security/2020/09/03/5
https://bugzilla.opensuse.org/show_bug.cgi?id=1176034
https://dev.gnupg.org/rG8ec9573e57866dda5efb4677d4454161517484bc
https://dev.gnupg.org/T5050
https://lists.gnupg.org/pipermail/gnupg-announce/2020q3/000448.html

Copyright 2021, cxsecurity.com

 

Back to Top