Vulnerability CVE-2021-39371


Published: 2021-08-23

Description:
An XML external entity (XXE) injection in PyWPS before 4.5.0 allows an attacker to view files on the application server filesystem by assigning a path to the entity. OWSLib 0.24.1 may also be affected.

Type:

CWE-611

(Information Exposure Through XML External Entity Reference)

CVSS2 => (AV:N/AC:L/Au:N/C:P/I:N/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
5/10
2.9/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
None
None
Affected software
Osgeo -> Pywps 
Github -> Owslib 

 References:
https://github.com/geopython/pywps/pull/616
https://github.com/geopython/OWSLib/issues/790

Copyright 2022, cxsecurity.com

 

Back to Top