Vulnerability CVE-2022-21661


Published: 2022-01-06   Modified: 2022-01-07

Description:
WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database. Due to improper sanitization in WP_Query, there can be cases where SQL injection is possible through plugins or themes that use it in a certain way. This has been patched in WordPress version 5.8.3. Older affected versions are also fixed via security release, that go back till 3.7.37. We strongly recommend that you keep auto-updates enabled. There are no known workarounds for this vulnerability.

See advisories in our WLB2 database:
Topic
Author
Date
Med.
WordPress Core 5.8.2 - 'WP_Query' SQL Injection
Aryan Chehreghan...
13.01.2022

Type:

CWE-89

(Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection'))

CVSS2 => (AV:N/AC:L/Au:N/C:P/I:N/A:N)

CVSS Base Score
Impact Subscore
Exploitability Subscore
5/10
2.9/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
None
None
Affected software
Wordpress -> Wordpress 
Debian -> Debian linux 

 References:
https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-6676-cqfm-gw84
https://wordpress.org/news/2022/01/wordpress-5-8-3-security-release/
https://github.com/WordPress/wordpress-develop/commit/17efac8c8ec64555eff5cf51a3eff81e06317214
https://www.zerodayinitiative.com/advisories/ZDI-22-020/
https://www.debian.org/security/2022/dsa-5039
http://packetstormsecurity.com/files/165540/WordPress-Core-5.8.2-SQL-Injection.html
https://www.exploit-db.com/exploits/50663

Copyright 2022, cxsecurity.com

 

Back to Top