Vulnerability CVE-2022-29251


Published: 2022-05-25   Modified: 2022-05-26

Description:
XWiki Platform Flamingo Theme UI is a tool that allows customization and preview of any Flamingo-based skin. Starting with versions 6.2.4 and 6.3-rc-1, a possible cross-site scripting vector is present in the `FlamingoThemesCode.WebHomeSheet` wiki page related to the "newThemeName" form field. The issue is patched in versions 12.10.11, 14.0-rc-1, 13.4.7, and 13.10.3. The easiest available workaround is to edit the wiki page `FlamingoThemesCode.WebHomeSheet` (with wiki editor) according to the suggestion provided in the GitHub Security Advisory.

Type:

CWE-116

(Improper Encoding or Escaping of Output)

 References:
https://jira.xwiki.org/browse/XWIKI-19294
https://github.com/xwiki/xwiki-platform/commit/bd935320bee3c27cf7548351b1d0f935f116d437
https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-vmhh-xh3g-j992

Copyright 2022, cxsecurity.com

 

Back to Top