Vulnerability CVE-2022-2945


Published: 2022-09-06

Description:
The WordPress Infinite Scroll ?? Ajax Load More plugin for WordPress is vulnerable to Directory Traversal in versions up to, and including, 5.5.3 via the 'type' parameter found in the alm_get_layout() function. This makes it possible for authenticated attackers, with administrative permissions, to read the contents of arbitrary files on the server, which can contain sensitive information.

Type:

CWE-22

(Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal'))

 References:
https://plugins.svn.wordpress.org/ajax-load-more/tags/5.5.4/README.txt
https://www.wordfence.com/vulnerability-advisories/#CVE-2022-2945
https://gist.github.com/Xib3rR4dAr/f9a4b4838154854ec6cde7d5deb76bf9

Copyright 2022, cxsecurity.com

 

Back to Top