Vulnerability CVE-2022-30976


Published: 2022-05-18

Description:
GPAC 2.0.0 misuses a certain Unicode utf8_wcslen (renamed gf_utf8_wcslen) function in utils/utf.c, resulting in a heap-based buffer over-read, as demonstrated by MP4Box.

Type:

CWE-125

(Out-of-bounds Read)

CVSS2 => (AV:N/AC:H/Au:N/C:P/I:N/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
4/10
4.9/10
4.9/10
Exploit range
Attack complexity
Authentication
Remote
High
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
None
Partial
Affected software
GPAC -> GPAC 

 References:
https://github.com/gpac/gpac/blob/105d67985ff3c3f4b98a98f312e3d84ae77a4463/share/doc/man/gpac.1#L2226-L2229
https://github.com/gpac/gpac/blob/105d67985ff3c3f4b98a98f312e3d84ae77a4463/src/utils/utf.c#L35-L59
https://github.com/gpac/gpac/issues/2179

Copyright 2022, cxsecurity.com

 

Back to Top