Vulnerability CVE-2022-31212


Published: 2022-07-17   Modified: 2022-07-18

Description:
An issue was discovered in dbus-broker before 31. It depends on c-uitl/c-shquote to parse the DBus service's Exec line. c-shquote contains a stack-based buffer over-read if a malicious Exec line is supplied.

See advisories in our WLB2 database:
Topic
Author
Date
High
dbus-broker-29 Memory Corruption
T. Weber
06.06.2022

 References:
https://sec-consult.com/vulnerability-lab/advisory/memory-corruption-vulnerabilities-dbus-broker/
https://github.com/bus1/dbus-broker/compare/v30...v31

Copyright 2022, cxsecurity.com

 

Back to Top