Vulnerability CVE-2022-31313


Published: 2022-06-08   Modified: 2022-06-09

Description:
api-res-py package in PyPI 0.1 is vulnerable to a code execution backdoor in the request package.

Type:

NVD-CWE-noinfo

CVSS2 => (AV:N/AC:L/Au:N/C:P/I:P/A:P)

CVSS Base Score
Impact Subscore
Exploitability Subscore
7.5/10
6.4/10
10/10
Exploit range
Attack complexity
Authentication
Remote
Low
No required
Confidentiality impact
Integrity impact
Availability impact
Partial
Partial
Partial
Affected software
Api-res-py project -> Api-res-py 

 References:
https://github.com/rakeshrkz7/as_api_res/issues/1
http://pypi.doubanio.com/simple/request
https://pypi.org/project/api-res-py/

Copyright 2022, cxsecurity.com

 

Back to Top