Vulnerability CVE-2022-39210


Published: 2022-09-17

Description:
Nextcloud android is the official Android client for the Nextcloud home server platform. Internal paths to the Nextcloud Android app files are not properly protected. As a result access to internal files of the from within the Nextcloud Android app is possible. This may lead to a leak of sensitive information in some cases. It is recommended that the Nextcloud Android app is upgraded to 3.21.0. There are no known workarounds for this issue.

Type:

CWE-22

(Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal'))

 References:
https://github.com/nextcloud/security-advisories/security/advisories/GHSA-vw2w-gpcv-v39f
https://github.com/nextcloud/android/pull/10544

Copyright 2022, cxsecurity.com

 

Back to Top