Vulnerability CVE-2023-4919


Published: 2023-10-20

Description:
The iframe plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the `iframe` shortcode in versions up to, and including, 4.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level permission and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This was partially patched in version 4.6 and fully patched in version 4.7.

 References:
https://plugins.trac.wordpress.org/browser/iframe/tags/4.5/iframe.php#L40
https://plugins.trac.wordpress.org/browser/iframe/tags/4.5/iframe.php#L28
https://www.wordfence.com/threat-intel/vulnerabilities/id/3706deed-55f2-4dfb-bfed-7a14872cd15a?source=cve
https://plugins.trac.wordpress.org/changeset/2970787/iframe#file4

Copyright 2026, cxsecurity.com

 

Back to Top